Ignite Christian Academy: Users Cannot Log in to Genius SIS
Incident Report for AOP Site
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 25, 2023 - 08:24 MST
Investigating
Students and Educators cannot log in to Genius Student Information System. We are working with Genius to resolve this issue.

We apologize for the inconvenience and will provide an update soon.
Posted Jul 25, 2023 - 08:04 MST
This incident affected: Ignite Christian Academy.