We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted Jul 08, 2024 - 11:29 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Jul 08, 2024 - 07:59 MST
Investigating
Our team is actively working on an issue impacting Monarch parents. When parents attempt to log in, they are presented an error message after entering their credentials.
We apologize for the inconvenience and will provide an update soon.