Monarch - Navigation Slowness

Incident Report for AOP Site

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Nov 21, 2025 - 09:19 MST

Investigating

We are investigating user reports of slowness when navigating between pages in Monarch.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 21, 2025 - 09:19 MST
This incident affected: Monarch.