Our team is actively working to restore all missing assignments. We anticipate the full restoration to be completed next week. We recognize the importance of this information and are taking every precaution to ensure that no data is lost.
Posted Nov 21, 2025 - 15:29 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.
We will continue to update progress.
Posted Nov 21, 2025 - 09:17 MST
Investigating
We are aware of some missing Monarch assignments that were submitted on November 20, 2025. We have the assignment data and are working to update the system with those records. If you would like your student to move past assignments lost, you can unassign the completed assignment in order for them to work on the next assignment.
We apologize for the inconvenience and will provide an update soon.